wordpress安装启用主题出现HTTP 500内部服务器错误的解决方法

部分wordpress博主在安装启用主题时,出现“HTTP 500内部服务器”的错误提示导致网站无法打开,出现这个问题的常见原因有网站使用的主机硬件配置较低,或者主机服务器环境的php版本过低,而主题使用的代码函数不支持低版本php,还有就是FTP没有使用二进制的上传方式。

解决方法:

1、FTP通过二进制方式上传,或者把主题文件夹压缩成.zip的格式,通过后台——外观——主题直接上传安装启用。

2、wordpress最低要求php 5.2.4+、MySQL 5.0+,但由于部分主题的代码函数原因,需要高版本的php,所以如果网站空间的php在5.3以下版本,那么联系空间提供商升级到php 5.3以上版本。(最常见的情况)

3、使用的网站空间配置太低太烂,比如内存太低,直接换主机。

发表留言