wordpress 5.0屏蔽Gutenberg编辑器恢复TinyMCE的方法

wordpress 5.0版本开始Gutenberg取代TinyMCE成为wordpress默认编辑器,但是由于新编辑器对自定义字段的支持不够完善,导致原来使用了Meta Box的主题或插件都失效,可能也是因为这个原因,wordpress官方发布了classic editor插件,通过classic editor插件可以让博主在Gutenberg编辑器和TinyMCE编辑器之间自由选择使用。

如果不打算使用Gutenberg编辑器,也可以使用下面的代码直接屏蔽Gutenberg编辑器,恢复TinyMCE编辑器。

把下面的代码放到主题的functions.php文件,保存文件即可恢复TinyMCE编辑器:

1
add_filter('use_block_editor_for_post_type', '__return_false');

发表留言