WordPress服务器PHP兼容性检查工具插件php compatibility checker

WordPress插件 957

PHP已经发展到8.0+版本,WordPress官方也推荐服务器使用PHP 7.4或更高版本有利于使网站安全性和高效性。当然由于PHP各版本之前的新旧差异,很难避免出现WordPress主题或插件不兼容新PHP版本的问题,因此升级到更新版本PHP前,对主题和插件进行PHP兼容性检查就很有必要,WordPress官方推荐安装PHP Compatibility Checker插件检查网站使用的主题和插件可能存在的问题,这个工具插件可以在任何服务器主机上的任何WordPress网站上使用。

php compatibility checker插件可以整理网站的主题和插件代码,并提供兼容性问题的报告,对主题和插件存在的问题分为错误和警告,并列出违规代码的文件和行号(所在位置)以及代码与所选PHP版本不兼容的原因信息。

同时还将建议更新主题和插件,因为新版本的主题和插件通常会对新版本PHP做好了兼容处理。

php compatibility checker使用方法:

1、下载安装主题:WordPress官网下载(或者后台搜索“php compatibility checker”安装)。

2、安装启用插件后,点击“后台——工具”下的“PHP Compatibility”进入插件使用界面:

WordPress服务器PHP兼容性检查工具插件php compatibility checker

  • Only scan active plugins and theme:只检查激活的插件和主题。
  • Scan all plugins and themes:检查所有插件和主题。

选择“只扫描激活的插件和主题”或者“扫描所有插件和主题”,一般来说选择前者就可以了。选择后“Scan Results for PHP Compatibility”会列出这次检查涉及到的插件和主题。

3、点击扫描站点按钮【Scan site】进行扫描:

WordPress服务器PHP兼容性检查工具插件php compatibility checker

  • Plugins打勾的5.6、7.0、7.1、7.2、7.3、7.4、8.0表示兼容的PHP版本。
  • Themes是响应失败,需要重新扫描。

提醒:虽然该插件的编写是为了尽可能准确地检测出更多问题,但检测无法保证 100% 可靠,在迁移到新的PHP版本之前的最佳做法是进行全面测试,建议先在电脑本地搭建相应的服务器环境测试没问题后再在服务器上更新。

精品推荐: