WordPress 博客系统将停止支持PHP 4及MySQL 4

目前我们使用的WordPress博客版本支持PHP否4和MYSQL 4版本,但是据WordPress官方消息称,明年上半年发布的WordPress 3.2版将不支持PHP 4和MYSQL 4的版本,也就是说今年(2010)年末发布的WordPress 3.1将会是最后一个支持PHP 4和MYSQL 4的博客版本。

详细消息:

据国外媒体报道,WordPress今天通过官方博客宣布,2010年末发布的WordPress 3.1将成最后一个支持PHP 4和MySQL 4的版本。明年上半年发布的WordPress 3.2则需要具备PHP 5.2或MySQL 5.0.15或以上版本。

WordPress表示,2010年末发布的WordPress 3.1将成为最后一个支持PHP 4的版本。将于2011年上半年发布的WordPress 3.2最低需要使用PHP 5.2,因为“这是绝大多数WordPress用户正在使用的版本,而且对早先的PHP 5进行了实质性改进”。而Drupal和Joomla等内容管理系统即将于今年晚些时候发布的最新版本也将PHP 5.2设定为最低要求。

数据显示,WordPress用户中目前只有11%使用PHP 5.2以下版本。在这些用户中,其实有很多主机已经可以支持PHP 5.2,只需要在控制面板中激活即可。WordPress认为,今后使用PHP 5.2以下版本的用户还将继续减少。

除此之外,在WordPress 3.1以后的版本也将停止对MySQL 4的支持。目前只有不到6%的WordPress用户使用MySQL 4。WordPress 3.2必须要使用MySQL 5.0.15及以上版本。

如果用户的托管环境不满足上述要求,便无法升级到WordPress 3.2。为了方便用户判断,WordPress还提供了一个名为“Health Check”的插件来帮助用户了解当前的托管主机是否满足WordPress 3.2的配置要求。

提示:消息来自新浪科技

提醒:今年购买网站空间搭建WordPress博客的博主,注意购买前先咨询空间的PHP和MYSQL版本,如果是PHP4和MYSQL4的,就再问一下到时是否会升级到 5.0.15及以上版本。

发表留言